ExportIFCCategoryInfo Class


Export IFCCategory Info Class

Represents the mapped IFC information stored in the template.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportIFCCategoryInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportIFCCategoryInfo : IDisposable

The ExportIFCCategoryInfo type exposes the following members.

Constructors
Name Description
Public method ExportIFCCategoryInfo Constructs a new ExportIFCCategoryInfo with default values.
Public method ExportIFCCategoryInfo(Boolean, String, String, String, String) Constructs a new ExportIFCCategoryInfo with input values.
Top
Properties
Name Description
Public property IFCEntityName The name of the IFC entity mapped to a particular Revit category.
Public property IFCExportFlag The boolean value that indicates whether the category is exported to ifc.
Public property IFCPredefinedType The name of the predefined type mapped to a particular Revit category.
Public property IFCPresentationLayerName The name of the presentation layer mapped to a particular Revit category.
Public property IFCUserDefinedType The name of the user-defined type mapped to a particular Revit category.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExportIFCCategoryInfo
Public method IsDefault Determines if a ExportIFCCategoryInfo contains default information.
Top
See Also