Analytical |
Represents the data and parameters of electrical analytical transfer switch.

System Object
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalPowerDistributableNodeData
Autodesk.Revit.DB.Electrical AnalyticalTransferSwitchData
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalPowerDistributableNodeData
Autodesk.Revit.DB.Electrical AnalyticalTransferSwitchData
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The AnalyticalTransferSwitchData type exposes the following members.

Name | Description | |
---|---|---|
![]() | AssignedPhasesNumber | The number of electrical phases assigned through the distribution system of the power distributable node. (Inherited from AnalyticalPowerDistributableNodeData ) |
![]() | AssignedVoltage | The voltage assigned through the distribution system of the power distributable node. (Inherited from AnalyticalPowerDistributableNodeData ) |
![]() | ConnectedPhases | The electrical connected phases of the electrical analytical node to its upstream node. (Inherited from AnalyticalDistributionNodePropertyData ) |
![]() | CurrentRating | The current rating value of the electrical analytical transfer switch. |
![]() | DistributionSystem | The distribution system of the power distributable node. (Inherited from AnalyticalPowerDistributableNodeData ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AnalyticalDistributionNodePropertyData ) |
![]() | NumberOfPhases | Obsolete. The number of electrical phases. (Inherited from AnalyticalDistributionNodePropertyData ) |
![]() | TotalConnectedCurrent | The total connected current of the electrical analytical transfer switch. |
![]() | Voltage | Obsolete. The voltage value of the electrical analytical transfer switch. |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from AnalyticalDistributionNodePropertyData ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetAllAvailableConnectedPhasesOnDownstream | Get all the available electrical connected phases that this power distributable node can provide to the downstream node. (Inherited from AnalyticalPowerDistributableNodeData ) |
![]() | GetApparentPerPhaseResults | Get an ElectricalPerPhaseData which contains each electrical phase's apparent load and apprent current of the power distributable node. (Inherited from AnalyticalPowerDistributableNodeData ) |
![]() | GetConnectedPhasesOnDownstream | Get the electrical connected phases of the downstream node. (Inherited from AnalyticalPowerDistributableNodeData ) |
![]() | GetDemandPerPhaseResults | Get an ElectricalPerPhaseData which contains each electrical phase's demand load and demand current of the power distributable node. (Inherited from AnalyticalPowerDistributableNodeData ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetConnectedPhasesOnDownstream | Set the electrical connected phases of the downstream node. (Inherited from AnalyticalPowerDistributableNodeData ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |