AnalyticalTransferSwitchData Class


Analytical Transfer Switch Data Class

Represents the data and parameters of electrical analytical transfer switch.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class AnalyticalTransferSwitchData : AnalyticalPowerDistributableNodeData

The AnalyticalTransferSwitchData type exposes the following members.

Properties
Name Description
Public property AssignedPhasesNumber The number of electrical phases assigned through the distribution system of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public property AssignedVoltage The voltage assigned through the distribution system of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public property ConnectedPhases The electrical connected phases of the electrical analytical node to its upstream node.
(Inherited from AnalyticalDistributionNodePropertyData )
Public property CurrentRating The current rating value of the electrical analytical transfer switch.
Public property DistributionSystem The distribution system of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AnalyticalDistributionNodePropertyData )
Public property TotalConnectedCurrent The total connected current of the electrical analytical transfer switch.
Top
Methods
Name Description
Public method Dispose
(Inherited from AnalyticalDistributionNodePropertyData )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetAllAvailableConnectedPhasesOnDownstream Get all the available electrical connected phases that this power distributable node can provide to the downstream node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public method GetApparentPerPhaseResults Get an ElectricalPerPhaseData which contains each electrical phase's apparent load and apprent current of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public method GetConnectedPhasesOnDownstream Get the electrical connected phases of the downstream node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public method GetDemandPerPhaseResults Get an ElectricalPerPhaseData which contains each electrical phase's demand load and demand current of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetConnectedPhasesOnDownstream Set the electrical connected phases of the downstream node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also