IsResolutionApplicable Method


Failure Definition Accessor Is Resolution Applicable Method

Checks if the given resolution type is applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsResolutionApplicable(
	FailureResolutionType type
)

Parameters

type FailureResolutionType
The resolution type to check.

Return Value

Boolean
True if the given resolution type is applicable to the failure, false otherwise.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException The FailureDefinitionAccessor has not been properly initialized.
See Also