FamilyParameter Class


Family Parameter Class

The family parameter object.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB FamilyParameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyParameter : APIObject

The FamilyParameter type exposes the following members.

Properties
Name Description
Public property AssociatedParameters The parameters from elements in the family which are associated to this parameter.
Public property CanAssignFormula Indicates if this parameter can be assigned a formula.
Public property Definition The definition.
Public property Formula The formula.
Public property Code example GUID The globally unique identifier
Public property Id The id of the family parameter.
Public property IsDeterminedByFormula Indicates if the parameter is determined by formula.
Public property IsInstance Indicates if the parameter is instance or type.
Public property IsReadOnly Identifies if the object is read-only or modifiable.
(Overrides APIObject IsReadOnly )
Public property IsReporting Indicates if the parameter is a reporting parameter.
Public property IsShared Identifies if the parameter is a shared parameter.
Public property StorageType The storage type describes the type that is used internally within the parameter to store its value.
Public property UserModifiable Indicates whether the interactive user can modify the value of this parameter.
Top
Methods
Name Description
Public method GetUnitTypeId Gets the identifier of the unit quantifying the parameter value.
Top
See Also