Metal Class


Metal Class

A static class that provides access to the property names that appear in the Metal visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Metal

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Metal

The Metal type exposes the following members.

Properties
Name Description
Public property Static member CommonTintColor The property labeled "Tint Color" from the "Metal" schema.
Public property Static member CommonTintToggle The property labeled "Tint" from the "Metal" schema.
Public property Static member MetalColor The property labeled "Color" from the "Metal" schema.
Public property Static member MetalFinish The property labeled "Finish" from the "Metal" schema.
Public property Static member MetalPatina The property labeled "Patina" from the "Metal" schema.
Public property Static member MetalPattern The property labeled "Relief Pattern" from the "Metal" schema.
Public property Static member MetalPatternHeight The property labeled "Amount" from the "Metal" schema.
Public property Static member MetalPatternScale The property labeled "Scale" from the "Metal" schema.
Public property Static member MetalPatternShader The property labeled "Image" from the "Metal" schema.
Public property Static member MetalPerforations The property labeled "Cutouts" from the "Metal" schema.
Public property Static member MetalPerforationsCenter The property labeled "Center Spacing" from the "Metal" schema.
Public property Static member MetalPerforationsShader The property labeled "Image" from the "Metal" schema.
Public property Static member MetalPerforationsSize The property labeled "Diameter/Size" from the "Metal" schema.
Public property Static member MetalType The property labeled "Type" from the "Metal" schema.
Top
See Also