Metal Class |
A static class that provides access to the property names that appear in the Metal visual asset schema.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The Metal type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | CommonTintColor | The property labeled "Tint Color" from the "Metal" schema. |
![]() ![]() | CommonTintToggle | The property labeled "Tint" from the "Metal" schema. |
![]() ![]() | MetalColor | The property labeled "Color" from the "Metal" schema. |
![]() ![]() | MetalFinish | The property labeled "Finish" from the "Metal" schema. |
![]() ![]() | MetalPatina | The property labeled "Patina" from the "Metal" schema. |
![]() ![]() | MetalPattern | The property labeled "Relief Pattern" from the "Metal" schema. |
![]() ![]() | MetalPatternHeight | The property labeled "Amount" from the "Metal" schema. |
![]() ![]() | MetalPatternScale | The property labeled "Scale" from the "Metal" schema. |
![]() ![]() | MetalPatternShader | The property labeled "Image" from the "Metal" schema. |
![]() ![]() | MetalPerforations | The property labeled "Cutouts" from the "Metal" schema. |
![]() ![]() | MetalPerforationsCenter | The property labeled "Center Spacing" from the "Metal" schema. |
![]() ![]() | MetalPerforationsShader | The property labeled "Image" from the "Metal" schema. |
![]() ![]() | MetalPerforationsSize | The property labeled "Diameter/Size" from the "Metal" schema. |
![]() ![]() | MetalType | The property labeled "Type" from the "Metal" schema. |