XYZ Dot |
The dot product of this vector and the specified vector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- source XYZ
- The vector to multiply with this vector.
Return Value
DoubleThe real number equal to the dot product.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when source is . |

The dot product is the sum of the respective coordinates of the two vectors: Vx*Wx + Vy*Wy + Vz*Wz. Also known as scalar product or inner product.