DotProduct Method


XYZ Dot Product Method

The dot product of this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double DotProduct(
	XYZ source
)

Parameters

source XYZ
The vector to multiply with this vector.

Return Value

Double
The real number equal to the dot product.
Exceptions
Exception Condition
ArgumentNullException Thrown when source is .
Remarks
The dot product is the sum of the respective coordinates of the two vectors: Vx*Wx + Vy*Wy + Vz*Wz. Also known as scalar product or inner product.
See Also