SeparatorItem Class


Separator Item Class

A class representing a context menu separator.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI MenuItem
Autodesk.Revit.UI SeparatorItem

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SeparatorItem : MenuItem

The SeparatorItem type exposes the following members.

Constructors
Name Description
Public method SeparatorItem Default constructor.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from MenuItem )
Top
Methods
Name Description
Public method Dispose
(Inherited from MenuItem )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
A separator can be added between menu items when needed.
See Also