Separator |
A class representing a context menu separator.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The SeparatorItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | SeparatorItem | Default constructor. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from MenuItem ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from MenuItem ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

A separator can be added between menu items when needed.