IsTypeValidForRepeater Method


Component Repeater Is Type Valid For Repeater Method

Determines whether given family type can be used as the default type for the repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsTypeValidForRepeater(
	ElementId typeId
)

Parameters

typeId ElementId
The element id of the type.

Return Value

Boolean
True if the family type can be used as the default type for the repeater.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also