ExportLayerKey Class


Export Layer Key Class

A key used to represent an item stored in an ExportLayerTable .
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportLayerKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportLayerKey : IDisposable

The ExportLayerKey type exposes the following members.

Constructors
Name Description
Public method ExportLayerKey Constructs a new ExportLayerKey with default values.
Public method ExportLayerKey(String, String, SpecialType) Constructs a new ExportLayerKey with categoryName, subCategoryName and a special type.
Top
Properties
Name Description
Public property CategoryName The category name.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SpecialType The special type for layer key.
Public property SubCategoryName The subcategrory Name.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExportLayerKey
Top
See Also