Export |
A key used to represent an item stored in an ExportLayerTable .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ExportLayerKey type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExportLayerKey | Constructs a new ExportLayerKey with default values. |
![]() | ExportLayerKey(String, String, SpecialType) | Constructs a new ExportLayerKey with categoryName, subCategoryName and a special type. |

Name | Description | |
---|---|---|
![]() | CategoryName | The category name. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SpecialType | The special type for layer key. |
![]() | SubCategoryName | The subcategrory Name. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ExportLayerKey |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |