CreateGroup Method


Light Group Manager Create Group Method

Create a new LightGroup object with the given name

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public LightGroup CreateGroup(
	string name
)

Parameters

name String
The name to use for the new LightGroup object

Return Value

LightGroup
The new LightGroup object that was created
Exceptions
Exception Condition
ArgumentException The name is not valid because it is not unique within this LightGroupManager -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
ArgumentNullException A non-optional argument was null
See Also