HorizontalCurveEndpoint Class


Horizontal Curve Endpoint Class

Represents an endpoint (start or end) of a horizontal curve in Alignment geometry.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Infrastructure HorizontalCurveEndpoint

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class HorizontalCurveEndpoint

The HorizontalCurveEndpoint type exposes the following members.

Properties
Name Description
Public property NextCurveType The HorizontalCurveType of the curve which connects the endpoint to the next displayed curve. If this endpoint's Station equals DisplayedEndStation , returns Unknown curve type.
Public property PreviousCurveType The HorizontalCurveType of the curve which connects the endpoint to the previous displayed curve. If this endpoint's Station equals DisplayedStartStation , returns Unknown curve type.
Public property Station The endpoint's station value.
Top
Methods
Name Description
Top
See Also