Horizontal |
Represents an endpoint (start or end) of a horizontal curve in Alignment geometry.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)

The HorizontalCurveEndpoint type exposes the following members.

Name | Description | |
---|---|---|
![]() | NextCurveType | The HorizontalCurveType of the curve which connects the endpoint to the next displayed curve. If this endpoint's Station equals DisplayedEndStation , returns Unknown curve type. |
![]() | PreviousCurveType | The HorizontalCurveType of the curve which connects the endpoint to the previous displayed curve. If this endpoint's Station equals DisplayedStartStation , returns Unknown curve type. |
![]() | Station | The endpoint's station value. |

Name | Description | |
---|---|---|