StdPostedWarning Class


Std Posted Warning Class

Support for Reviewable Warnings sent from AddOn.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB StdPostedWarning

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StdPostedWarning : IDisposable

The StdPostedWarning type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the StdPostedWarning
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Used to create and send Reviewable Warning from AddOn.
See Also