Fill |
Represents a grid line in a fill pattern.

System Object
Autodesk.Revit.DB FillGrid
Autodesk.Revit.DB FillGrid
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The FillGrid type exposes the following members.

Name | Description | |
---|---|---|
![]() | FillGrid | Creates a simple fill grid. |
![]() | FillGrid(FillGrid) | Constructs a new FillGrid with default settings. |
![]() | FillGrid(Double, Double) | Creates a simple fill grid with given angle and offset. |

Name | Description | |
---|---|---|
![]() | Angle | Gets and sets the angle of the fill grid. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Offset | Gets and sets the offset of the fill grid. |
![]() | Origin | Gets and sets the origin of the fill grid. |
![]() | Shift | Gets and sets the shift of the fill grid. |

Name | Description | |
---|---|---|
![]() | CalculateLengthPerArea | Calculates length of the pattern per unit area. |
![]() | CalculateLinesPerLength | Calculates the number of solid lines of the pattern per unit length. |
![]() | CalculateStrokesPerArea | Calculates the number of the segments of the pattern per unit area. |
![]() | Dispose | Releases all resources used by the FillGrid |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetHatchingDirection | Provides the hatching propagation. Hatching is inverted. |
![]() | GetPointLineZone(UV) | Gets the index of fill grid line closest to the input 2d point. |
![]() | GetPointLineZone(UV, UV ) | Gets the index of fill grid line and the point on the grid line nearest to the input point. |
![]() | GetSegmentDirection | Provides the segment direction. |
![]() | GetSegments | Gets the segments of the fill grid. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsEqual | Check if two fill grids are equal. |
![]() | SetSegments | |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

A grid line is described in the two dimensions of a face as follows: angle, origin, shift, offset, segments
- Angle specifies the direction, in degrees, of the grid line relative to the x-axis.
- Parallel lines are drawn as specified by Offset and Shift to fill the entire face. Offset defines the distance between parallel lines. Zero Offset is not allowed. Shift moves the pattern of dashes and spaces along the length of each new parallel line. Shift is ignored if the line is solid.
- The segments defines a repeating pattern of dashes and spaces for the grid line. If it is omitted, the line is solid. Positive numbers define dashes, negative numbers define spaces, and zero specifies a dot. If you begin a pattern with a space, do not alternate dashes and spaces, or do not end with a space, Revit will introduce tiny dashes or spaces to compensate. Revit expands dots and very short dashes into dashes of a minimum size.