FillGrid Class


Fill Grid Class

Represents a grid line in a fill pattern.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FillGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FillGrid : IDisposable

The FillGrid type exposes the following members.

Constructors
Name Description
Public method FillGrid Creates a simple fill grid.
Public method FillGrid(FillGrid) Constructs a new FillGrid with default settings.
Public method FillGrid(Double, Double) Creates a simple fill grid with given angle and offset.
Top
Properties
Name Description
Public property Angle Gets and sets the angle of the fill grid.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Offset Gets and sets the offset of the fill grid.
Public property Origin Gets and sets the origin of the fill grid.
Public property Shift Gets and sets the shift of the fill grid.
Top
Methods
Name Description
Public method CalculateLengthPerArea Calculates length of the pattern per unit area.
Public method CalculateLinesPerLength Calculates the number of solid lines of the pattern per unit length.
Public method CalculateStrokesPerArea Calculates the number of the segments of the pattern per unit area.
Public method Dispose Releases all resources used by the FillGrid
Public method GetHatchingDirection Provides the hatching propagation. Hatching is inverted.
Public method GetPointLineZone(UV) Gets the index of fill grid line closest to the input 2d point.
Public method GetPointLineZone(UV, UV ) Gets the index of fill grid line and the point on the grid line nearest to the input point.
Public method GetSegmentDirection Provides the segment direction.
Public method GetSegments Gets the segments of the fill grid.
Public method IsEqual Check if two fill grids are equal.
Public method SetSegments Sets the segments to the fill grid.
Top
Remarks
A grid line is described in the two dimensions of a face as follows: angle, origin, shift, offset, segments
  • Angle specifies the direction, in degrees, of the grid line relative to the x-axis.
  • Parallel lines are drawn as specified by Offset and Shift to fill the entire face. Offset defines the distance between parallel lines. Zero Offset is not allowed. Shift moves the pattern of dashes and spaces along the length of each new parallel line. Shift is ignored if the line is solid.
  • The segments defines a repeating pattern of dashes and spaces for the grid line. If it is omitted, the line is solid. Positive numbers define dashes, negative numbers define spaces, and zero specifies a dot. If you begin a pattern with a space, do not alternate dashes and spaces, or do not end with a space, Revit will introduce tiny dashes or spaces to compensate. Revit expands dots and very short dashes into dashes of a minimum size.
See Also