ExecutedEventArgs Class


Executed Event Args Class

The event arguments used by AddInCommandBinding's Executed event.
Inheritance Hierarchy
System Object
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.UI.Events CommandEventArgs
Autodesk.Revit.UI.Events ExecutedEventArgs

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ExecutedEventArgs : CommandEventArgs

The ExecutedEventArgs type exposes the following members.

Properties
Name Description
Public property ActiveDocument The active document.
(Inherited from CommandEventArgs )
Public property Cancel Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
(Inherited from RevitEventArgs )
Public property Cancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitEventArgs )
Public property CommandId The command id.
(Inherited from CommandEventArgs )
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetJournalData Gets the journal data associated to this command (on journal playback).
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetJournalData
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also