RebarSpliceGeometry Class


Rebar Splice Geometry Class

This class consists of a vector and a point which will be projected to the nearest Rebar curve.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarSpliceGeometry

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarSpliceGeometry : IDisposable

The RebarSpliceGeometry type exposes the following members.

Constructors
Name Description
Public method RebarSpliceGeometry Constructs a RebarSpliceGeometry.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SpliceNormal Identifies the splice face normal.
Public property SpliceOrigin Identifies the splice face origin.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarSpliceGeometry
Top
Remarks

The splice will be done with a plane that contains this point and has the normal the provided vector.

If this plane is intersecting other Rebar curves these intersection will not be taken into account.

See Also