Rebar |
This class consists of a vector and a point which will be projected to the nearest Rebar curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarSpliceGeometry type exposes the following members.

Name | Description | |
---|---|---|
![]() | RebarSpliceGeometry | Constructs a RebarSpliceGeometry. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SpliceNormal | Identifies the splice face normal. |
![]() | SpliceOrigin | Identifies the splice face origin. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the RebarSpliceGeometry |

The splice will be done with a plane that contains this point and has the normal the provided vector.
If this plane is intersecting other Rebar curves these intersection will not be taken into account.