ExternallyTaggedNonBReps Class


Externally Tagged Non BReps Class

Holds a collection of ExternallyTaggedNonBRep instances.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternallyTaggedNonBReps

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternallyTaggedNonBReps : IDisposable

The ExternallyTaggedNonBReps type exposes the following members.

Constructors
Name Description
Public method ExternallyTaggedNonBReps Make a new empty collection of ExternallyTaggedNonBRep instances.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Add Adds a copy of the input ExternallyTaggedNonBRep to this collection.
Public method CanAddExternallyTaggedNonBRep Checks if the input geometry could be added to this collection or not.
Public method Dispose Releases all resources used by the ExternallyTaggedNonBReps
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also