IDirectContext3DServer Interface


IDirect Context 3DServer Interface

The interface to be implemented by a server of the DirectContext3D external service.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IDirectContext3DServer : IExternalServer

The IDirectContext3DServer type exposes the following members.

Methods
Name Description
Public method CanExecute Can be used to allow the server to execute only in certain views.
Public method GetApplicationId Reports this server's application ID.
Public method GetBoundingBox Reports a bounding box of the geometry that this server submits for drawing.
Public method GetDescription Implement this method to return a description of the server.
(Inherited from IExternalServer )
Public method GetName Implement this method to return the name of the server.
(Inherited from IExternalServer )
Public method GetServerId Implement this method to return the id of the server.
(Inherited from IExternalServer )
Public method GetServiceId Implement this method to return the id of the service.
(Inherited from IExternalServer )
Public method GetSourceId Reports this server's source ID.
Public method GetVendorId Implement this method to return the id of the vendor of the server.
(Inherited from IExternalServer )
Public method RenderScene Performs rendering of the scene that the server creates.
Public method UseInTransparentPass Indicates whether this server will submit geometry during the rendering pass for transparent geometry.
Public method UsesHandles Tests whether this server uses DirectContext3D handle elements.
Top
See Also