IDirect |
The interface to be implemented by a server of the DirectContext3D external service.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The IDirectContext3DServer type exposes the following members.

Name | Description | |
---|---|---|
![]() | CanExecute | Can be used to allow the server to execute only in certain views. |
![]() | GetApplicationId | Reports this server's application ID. |
![]() | GetBoundingBox | Reports a bounding box of the geometry that this server submits for drawing. |
![]() | GetSourceId | Reports this server's source ID. |
![]() | RenderScene | Performs rendering of the scene that the server creates. |
![]() | UseInTransparentPass | Indicates whether this server will submit geometry during the rendering pass for transparent geometry. |
![]() | UsesHandles | Tests whether this server uses DirectContext3D handle elements. |