Profile Class |
A geometric profile consisting of a loop of curves.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB Profile
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB Profile
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The Profile type exposes the following members.

Name | Description | |
---|---|---|
![]() | Curves | Retrieve the curves that make up the boundary of the profile. |
![]() | Filled | Get or set whether the profile is filled. |
![]() | Transformed | Transforms this profile and returns the result. |

Name | Description | |
---|---|---|
![]() | Clone | Returns a copy of this profile. |

The profile may be filled.