OnSharedFamilyFound Method


IFamily Load Options On Shared Family Found Method

A method called when the shared family was found in the target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
bool OnSharedFamilyFound(
	Family sharedFamily,
	bool familyInUse,
	out FamilySource source,
	out bool overwriteParameterValues
)

Parameters

sharedFamily Family
The shared family in the current family document.
familyInUse Boolean
Indicates if one or more instances of the family is placed in the project.
source FamilySource
This indicates if the family will load from the project or the current family.
overwriteParameterValues Boolean
This indicates whether or not to overwrite the parameter values of existing types.

Return Value

Boolean
Return true to continue loading the family, false to cancel.
Remarks
Triggered only when the family is both loaded and changed.
See Also