GetLayerFunction Method


Compound Structure Get Layer Function Method

Retrieves the function of the specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public MaterialFunctionAssignment GetLayerFunction(
	int layerIdx
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.

Return Value

MaterialFunctionAssignment
The function of the layer.
Exceptions
Exception Condition
ArgumentOutOfRangeException The layer index is out of range.
Remarks
The function determines how this layer interacts with the layers of other elements to which it is joined.
See Also