Compound
|
Retrieves the function of the specified layer.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- layerIdx Int32
- Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
Return Value
MaterialFunctionAssignmentThe function of the layer.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | The layer index is out of range. |

The function determines how this layer interacts with the layers of other elements to which it is joined.