Rebar |
This class is used to contain the information about the rebar handles defined by an external application.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarHandlesData type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | AddCustomHandle | Adds a new handle definition to the rebar. This information is set to the rebar after the API execution is finished successfully. |
![]() | Dispose | Releases all resources used by the RebarHandlesData |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetCustomHandles | Gets the handle definitions for the rebar that were added. |
![]() | GetEndHandle | Gets the end handle tag. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetStartHandle | Gets the start handle tag. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetEndHandle | Sets the end handle tag. This information is set to the rebar after the API execution is finished successfully. |
![]() | SetStartHandle | Sets the start handle tag. This information is set to the rebar after the API execution is finished successfully. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

All handle tags (custom, start, end) should have different values.