Rebar |
This class is used to contain the information about the rebar handles defined by an external application.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarHandlesData type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | AddCustomHandle | Adds a new handle definition to the rebar. This information is set to the rebar after the API execution is finished successfully. |
![]() | Dispose | Releases all resources used by the RebarHandlesData |
![]() | GetCustomHandles | Gets the handle definitions for the rebar that were added. |
![]() | GetEndHandle | Gets the end handle tag. |
![]() | GetStartHandle | Gets the start handle tag. |
![]() | SetEndHandle | Sets the end handle tag. This information is set to the rebar after the API execution is finished successfully. |
![]() | SetStartHandle | Sets the start handle tag. This information is set to the rebar after the API execution is finished successfully. |

All handle tags (custom, start, end) should have different values.