RebarHandlesData Class


Rebar Handles Data Class

This class is used to contain the information about the rebar handles defined by an external application.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarHandlesData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarHandlesData : IDisposable

The RebarHandlesData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method AddCustomHandle Adds a new handle definition to the rebar. This information is set to the rebar after the API execution is finished successfully.
Public method Dispose Releases all resources used by the RebarHandlesData
Public method GetCustomHandles Gets the handle definitions for the rebar that were added.
Public method GetEndHandle Gets the end handle tag.
Public method GetStartHandle Gets the start handle tag.
Public method SetEndHandle Sets the end handle tag. This information is set to the rebar after the API execution is finished successfully.
Public method SetStartHandle Sets the start handle tag. This information is set to the rebar after the API execution is finished successfully.
Top
Remarks
All handle tags (custom, start, end) should have different values.
See Also