Filter |
A filter rule that matches elements of a set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The FilterCategoryRule type exposes the following members.

Name | Description | |
---|---|---|
![]() | FilterCategoryRule | Initializes a new instance of the FilterCategoryRule class |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule ) |

Name | Description | |
---|---|---|
![]() ![]() | AllCategoriesFilterable | |
![]() | Dispose | (Inherited from FilterRule ) |
![]() | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetCategories | Gets the rule's categories. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetCategories | |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |