FilterCategoryRule Class


Filter Category Rule Class

A filter rule that matches elements of a set of categories.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FilterRule
Autodesk.Revit.DB FilterCategoryRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterCategoryRule : FilterRule

The FilterCategoryRule type exposes the following members.

Constructors
Name Description
Public method FilterCategoryRule Constructs a new instance of FilterCategoryRule.
Top
Properties
Name Description
Top
Methods
Name Description
Public method Static member AllCategoriesFilterable Checks that all of the given categories are filterable.
Public method GetCategories Gets the rule's categories.
Public method SetCategories Sets the rule's categories.
Top
See Also