Plan |
This class represents the view range of a plan view or a plan region. It records the element ids of the levels which a plane is relative to and the offset of each plane from that level.

System Object
Autodesk.Revit.DB PlanViewRange
Autodesk.Revit.DB PlanViewRange
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The PlanViewRange type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | Current | View range for the current plane |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() ![]() | LevelAbove | View range for the level above the specified plane |
![]() ![]() | LevelBelow | View range for the level below the specified plane |
![]() ![]() | Unlimited | View range is unlimited |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the PlanViewRange |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetLevelId | Get the element id of the level for a View Depth plane |
![]() | GetOffset | Get the offset value associated with a View Depth plane |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetLevelId | Set the level for a View Depth plane |
![]() | SetOffset | Set the offset value associated with a View Depth plane |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |