PlanViewRange Class


Plan View Range Class

This class represents the view range of a plan view or a plan region. It records the element ids of the levels which a plane is relative to and the offset of each plane from that level.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB PlanViewRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PlanViewRange : IDisposable

The PlanViewRange type exposes the following members.

Properties
Name Description
Public property Static member Current View range for the current plane
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Static member LevelAbove View range for the level above the specified plane
Public property Static member LevelBelow View range for the level below the specified plane
Public property Static member Unlimited View range is unlimited
Top
Methods
Name Description
Public method Dispose Releases all resources used by the PlanViewRange
Public method GetLevelId Get the element id of the level for a View Depth plane
Public method GetOffset Get the offset value associated with a View Depth plane
Public method SetLevelId Set the level for a View Depth plane
Public method SetOffset Set the offset value associated with a View Depth plane
Top
Example
private ElementId GetViewRangeTopClipPlane(Document doc, View view)
{
    ElementId topClipPlane = ElementId.InvalidElementId;

    if (view is ViewPlan)
    {
        ViewPlan viewPlan = view as ViewPlan;
        PlanViewRange viewRange = viewPlan.GetViewRange();

        topClipPlane = viewRange.GetLevelId(PlanViewPlane.TopClipPlane);
        double dOffset = viewRange.GetOffset(PlanViewPlane.TopClipPlane);

        if (topClipPlane != ElementId.InvalidElementId)
        {
            Element levelAbove = doc.GetElement(topClipPlane);
            TaskDialog.Show(view.Name, "Top Clip Plane: " + levelAbove.Name + "\r\nTop Offset: " + dOffset + " ft");
        }
    }

    return topClipPlane;
}
See Also