Analytical |
Sets the Curve Loop that defines the geometry of the Analytical Surface element.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- outerContour CurveLoop
- New Curve Loop for the Analytical Surface element.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Curve Loop must be planar and not self-intersecting.