SetOuterContour Method


Analytical Surface Base Set Outer Contour Method

Sets the Curve Loop that defines the geometry of the Analytical Surface element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetOuterContour(
	CurveLoop outerContour
)

Parameters

outerContour CurveLoop
New Curve Loop for the Analytical Surface element.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Curve Loop must be planar and not self-intersecting.
See Also