ObjectSnapTypes Enumeration


Object Snap Types Enumeration

This enumerated type contains object snap types allowed to be set during PickPoint operations.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
[FlagsAttribute]
public enum ObjectSnapTypes
Members
Member name Value Description
Centers 32 Snaps to the center of an arc.
CoordinationModelPoints 2,048 Snaps to Coordination Model points.
Endpoints 1 Snaps to the endpoint of an element or component.
Intersections 16 Snaps to intersections.
Midpoints 2 Snaps to the midpoint of an element or component.
Nearest 4 Snaps to the nearest element or component.
None 0 Snaps to nothing.
Perpendicular 64 Snaps to perpendicular elements or components.
Points 512 Snaps to site points.
Quadrants 256 Snaps to quadrant points. For arcs, jump snaps are enabled.
Remote 1,024 Remote snaps to objects.
Tangents 128 Snaps tangent to an arc.
WorkPlaneGrid 8 Snaps to a work plane grid.
See Also