ObjectSnapTypes Enumeration


Object Snap Types Enumeration

This enumerated type contains object snap types allowed to be set during PickPoint operations.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[FlagsAttribute]
public enum ObjectSnapTypes
Members
Member name Value Description
None 0 Snaps to nothing.
Endpoints 1 Snaps to the endpoint of an element or component.
Midpoints 2 Snaps to the midpoint of an element or component.
Nearest 4 Snaps to the nearest element or component.
WorkPlaneGrid 8 Snaps to a work plane grid.
Intersections 16 Snaps to intersections.
Centers 32 Snaps to the center of an arc.
Perpendicular 64 Snaps to perpendicular elements or components.
Tangents 128 Snaps tangent to an arc.
Quadrants 256 Snaps to quadrant points. For arcs, jump snaps are enabled.
Points 512 Snaps to site points.
Remote 1,024 Remote snaps to objects.
CoordinationModelPoints 2,048 Snaps to Coordination Model points.
See Also