RebarShapeParameters Class


Rebar Shape Parameters Class

Class containing functions that create and retrieve shared parameters for RebarShapes.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeParameters

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeParameters : IDisposable

The RebarShapeParameters type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarShapeParameters
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Static member GetAllRebarShapeParameters List all shape parameters used by all the existing RebarShapes in the specified document.
Public method Static member GetElementIdForExternalDefinition Retrieve the ElementId corresponding to an external rebar shape parameter in the document, if it exists; otherwise, return InvalidElementId.
Public method Static member GetExternalDefinitionForElementId Seach a DefinitionFile for the ExternalDefinition corresponding to a parameter in a document.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Static member GetOrCreateElementIdForExternalDefinition Retrieve the ElementId corresponding to an external rebar shape parameter in the document, if it exists; otherwise, add the parameter to the document and generate a new ElementId.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Static member IsValidExternalDefinition Checks that an ExternalDefinition (shared parameter) may be used as a Rebar Shape parameter.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also