ElementLevelFilter Class


Element Level Filter Class

A filter used to match elements by their associated level.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB ElementLevelFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementLevelFilter : ElementSlowFilter

The ElementLevelFilter type exposes the following members.

Constructors
Name Description
Public method ElementLevelFilter(ElementId) Constructs a new instance of an ElementLevelFilter.
Public method ElementLevelFilter(ElementId, Boolean) Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.
Top
Properties
Name Description
Public property LevelId The id of the level that will be matched to elements' associated level.
Top
Methods
Name Description
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
See Also