Element |
A filter used to match elements by their associated level.

System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB ElementLevelFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB ElementLevelFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ElementLevelFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | ElementLevelFilter(ElementId) | Constructs a new instance of an ElementLevelFilter. |
![]() | ElementLevelFilter(ElementId, Boolean) | Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id. |

Name | Description | |
---|---|---|
![]() | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter ) |
![]() | LevelId | The id of the level that will be matched to elements' associated level. |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from ElementFilter ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter ) |
![]() | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

// Use ElementLevel filter to find elements by their associated level in the document
// Find the level whose Name is "Level 1"
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> levels = collector.OfClass(typeof(Level)).ToElements();
var query = from element in collector where element.Name == "Level 1" select element;// Linq query
// Get the level id which will be used to match elements
List<Element> level1 = query.ToList<Element>();
ElementId levelId = level1[0].Id;
// Find all walls on level one
ElementLevelFilter level1Filter = new ElementLevelFilter(levelId);
collector = new FilteredElementCollector(document);
ICollection<Element> allWallsOnLevel1 = collector.OfClass(typeof(Wall)).WherePasses(level1Filter).ToElements();
// Find all rooms not on level one: use an inverted ElementLevelFilter to match all elements not on the target level
ElementLevelFilter notOnLevel1Filter = new ElementLevelFilter(levelId, true); // Inverted filter
collector = new FilteredElementCollector(document);
IList<Element> allRoomsNotOnLevel1 = collector.WherePasses(new RoomFilter()).WherePasses(notOnLevel1Filter).ToElements();