PointOnEdgeEdgeIntersection Class


Point On Edge Edge Intersection Class

Define a ReferencePoint at the intersection of two referenceable lines.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB PointElementReference
Autodesk.Revit.DB PointOnEdgeEdgeIntersection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointOnEdgeEdgeIntersection : PointElementReference

The PointOnEdgeEdgeIntersection type exposes the following members.

Methods
Name Description
Public method GetEdgeReference1 Get a copy of the first edge or curve reference.
Public method GetEdgeReference2 Get a copy of the second edge or curve reference.
Public method SetEdgeReference1 Change the first edge or curve reference.
Public method SetEdgeReference2 Change the second edge or curve reference.
Top
Remarks
The ReferencePoint is actually placed on the first line (Edge1) at the closest point to the second line (Edge2). Its X basis vector is constrained to be parallel to the first line.
See Also