Point |
Define a ReferencePoint at the intersection of two referenceable lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PointOnEdgeEdgeIntersection type exposes the following members.

Name | Description | |
---|---|---|
![]() | GetEdgeReference1 | Get a copy of the first edge or curve reference. |
![]() | GetEdgeReference2 | Get a copy of the second edge or curve reference. |
![]() | SetEdgeReference1 | Change the first edge or curve reference. |
![]() | SetEdgeReference2 | Change the second edge or curve reference. |

The ReferencePoint is actually placed on the first line (Edge1) at the closest point to the second line (Edge2). Its X basis vector is constrained to be parallel to the first line.