Point |
Define a ReferencePoint at the intersection of two referenceable lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PointOnEdgeEdgeIntersection type exposes the following members.

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetEdgeReference1 | Get a copy of the first edge or curve reference. |
![]() | GetEdgeReference2 | Get a copy of the second edge or curve reference. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetEdgeReference1 | Change the first edge or curve reference. |
![]() | SetEdgeReference2 | Change the second edge or curve reference. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The ReferencePoint is actually placed on the first line (Edge1) at the closest point to the second line (Edge2). Its X basis vector is constrained to be parallel to the first line.