Direct |
Tests whether a DirectShape or a DirectShapeType may be created in this document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- Document to be tested.
Return Value
BooleanTrue if a DirectShape or a DirectShapeType object can be created in this document, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Some types of Document, such as 2D families, can't support DirectShape functionality.