IsSupportedDocument Method


Direct Shape Is Supported Document Method

Tests whether a DirectShape or a DirectShapeType may be created in this document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsSupportedDocument(
	Document document
)

Parameters

document Document
Document to be tested.

Return Value

Boolean
True if a DirectShape or a DirectShapeType object can be created in this document, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Some types of Document, such as 2D families, can't support DirectShape functionality.
See Also