SubMenuItem Class


Sub Menu Item Class

A class representing a menu flyout.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI MenuItem
Autodesk.Revit.UI SubMenuItem

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SubMenuItem : MenuItem

The SubMenuItem type exposes the following members.

Constructors
Name Description
Public method SubMenuItem Initialize the item data.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from MenuItem )
Top
Methods
Name Description
Public method Dispose
(Inherited from MenuItem )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks

To add a child menu, create a new ContextMenu object and add MenuItem on it, pass the child ContextMenu object to SubMenuItem constructor and create SubMenuItem object, use AddItem() method to add the SubMenuItem object to parent ContextMenu.

See Also