Sub |
A class representing a menu flyout.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The SubMenuItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | SubMenuItem | Initialize the item data. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from MenuItem ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from MenuItem ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

To add a child menu, create a new ContextMenu object and add MenuItem on it, pass the child ContextMenu object to SubMenuItem constructor and create SubMenuItem object, use AddItem() method to add the SubMenuItem object to parent ContextMenu.