Sub |
A class representing a menu flyout.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The SubMenuItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | SubMenuItem | Initialize the item data. |

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|

To add a child menu, create a new ContextMenu object and add MenuItem on it, pass the child ContextMenu object to SubMenuItem constructor and create SubMenuItem object, use AddItem() method to add the SubMenuItem object to parent ContextMenu.