SpliceRebar(Document, ElementId, RebarSpliceOptions, IList<RebarSpliceGeometry>) Method


Rebar Splice Utils Splice Rebar(Document, Element Id, Rebar Splice Options, IList Rebar Splice Geometry ) Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static IList<ElementId> SpliceRebar(
	Document document,
	ElementId rebarIdToSplit,
	RebarSpliceOptions spliceOptions,
	IList<RebarSpliceGeometry> spliceGeometries
)

Parameters

document Document
rebarIdToSplit ElementId
spliceOptions RebarSpliceOptions
spliceGeometries IList RebarSpliceGeometry

Return Value

IList ElementId
See Also